เกริ่นนำ

บทความสำหรับผู้ที่มีความรู้เกี่ยวกับระบบเครือข่ายในระดับเบื้องต้นถึงปานกลางและในวันนี้ผมจะมานำเสนอการบล็อค  Bittorrent และบล็อค Web ด้วย web proxy และกำนดเครื่องที่ต้องการปล็ดบล็อคและทำการบล็อค Web และ Facebook

ขั้นตอน

Blockwebdiagram

ข้อมูลเบื้องต้นในการทำบทความนี้
– port 1 (mikrotik) – ขา WAN
– port 4 (mikrotik) – IP:192.168.105.1 ปล่อย hotspot วง 192.168.105.0/24

วิธีการตั้งค่า

การบล็อค  Bittorrent
กฏที่ 1

1

2

3

Code

^(\x13bittorrent protocol|azver\x01$|get /scrape\?info_hash=get /announce\?info_hash=|
get /client/bitcomet/|GET /data\?fid=)|d1:ad2:id20:|\x08'7P\)[RP]

4

5

6

7

กฏที่ 2

8

9

7

A8
กฏที่ 3

11

12

13

กฏที่ 4


14

15

13

จะได้ตามรูปด้านล่าง

17

การกำหนด IP เครื่องที่ต้องการปล็ดบล็อค

ตรงช่อง Address :  ให้ใส่ IP ที่ต้องการใช้งาน

2-1

จะได้ตามรูปด้านล่าง

2-2

ทดสอบ

ก่อนที่จะบล็อค

สามารถโหลด bittorrent ได้ปกติ

BeforBlockbit
หลังบล็อค
ไม่สามารถโหลด bittorrent ได้

afterBlockbit

การบล็อค Web

 

/ip proxy
set enabled=yes
set src-address=0.0.0.0
set port=8080
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator="webmaster"
set max-cache-size=none
set cache-on-disk=no
set max-client-connections=600
set max-server-connections=600
set max-fresh-time=3d
set always-from-cache=no
set cache-hit-dscp=4
set serialize-connections=no

 

Lab2_1

 

ดูการตั้งค่าได้ที่
1
สร้าง Firewall

/ip firewall nat add action=redirect chain=dstnat disabled=no 
dst-port=80 protocol=tcp to-ports=8080

ดูการตั้งค่าได้ที่

Lab2_3
กำหนด Firewall Filter

/ip firewall filter
add action=drop chain=input comment="Block Other Proxy" disabled=no
 dst-port=8080 in-interface=eth2 protocol=tcp src-address=0.0.0.0/0

–in-interface ให้เปลี่ยนเป็น Interface ที่ใช้งาน

กำหนด Web Proxy Access

/ip proxy access
add dst-host=www.appinventorthai.com action=allow
add dst-host=www.mikrotikthai.com action=allow
add action=deny

—    add dst-host=www.google.com action=allow ถ้า  action=allow สามารถเข้าเว็ปได้

—    add dst-host=www.google.com action=deny  ถ้า  action=deny ไม่สามารถเข้าเว็ปได้

Lab2_5
ทดสอบ

testgoogle

ไม่สามารถเข้า google ได้

หรือการบล็อค facebook 

/ip firewall filter
add chain=forward action=accept src-address=192.168.0.0/24 
protocol=tcp dst-port=80,443
add chain=input action=accept src-address=192.168.0.0/24 
protocol=tcp dst-port=80,443
add chain=forward action=drop src-address=0.0.0.0/0 
protocol=tcp dst-port=80,443
add chain=input action=drop src-address=0.0.0.0/0 
protocol=tcp dst-port=80,443

จะได้ตามรูป

bfacebook

บทสรุป

จากบทความข้องต้นจะเป็นการสอนตั้งค่า Firewall  สำหรับ Mikrotik เพื่อทำการบล็อคเว็ปต่างๆสามารถนำไปประยุคใช้ในองค์การหรือบริษัทต่างๆได้

อ้างอิง

 

  • http://www.sysnetcenter.com/board/index.php?topic=2213.0 — เพื่อศึกษาการบล็อคเว็ป
  • http://www.sys2u.com/xpert/viewtopic.php?f=53&t=14508&sid=3a1c95692b627fc3e8380b3f28562594–เพื่อศึกษาการทำ Web proxy access